The dependency problem occurred while installing subversion package on Linux CentOS/Red Hat with installed cPanel:

Missing Dependency: perl(URI) >= 1.17 is needed by package subversio

To fix this:

edit file /etc/yum.conf
and remove perl* from exclude section