If a site require a certificate authentication- puppeteer will throw out navigation error – we can’t handle it.

Sitespeed seems to use the normal Chrome instead of Chromium